BHM Forum      
Subscribe to Backwoods Home Magazine print or Kindle editions
Office Hours Momday - Friday  8 am - 5 pm Pacific 1-800-835-2418

Facebook   YouTube   Twitter
Follow Us!



 
Backwoods Home Magazine, self-reliance, homesteading, off-grid

Features
 Home Page
 Current Issue
 Article Index
 Author Index
 Previous Issues
 Newsletter
 Letters
 Humor
 Free Stuff
 Recipes
 Print Classifieds

General Store
 Ordering Info
 Subscriptions
 Kindle Subscriptions
 ePublications
 Anthologies
 Books
 Back Issues
 Help Yourself
 All Specials
 Classified Ad

Advertise
 Web Site Ads
 Magazine Ads

BHM Blogs
 Ask Jackie Clay
 Massad Ayoob
 Claire Wolfe
 James Kash
 Where We Live
 Behind The Scenes
 Dave on Twitter
Retired Blogs
 Oliver Del Signore
 David Lee
 Energy Questions
 Bramblestitches

Quick Links
 Home Energy Info
 Jackie Clay
 Ask Jackie Online
 Dave Duffy
 Massad Ayoob
 John Silveira
 Claire Wolfe

Forum / Chat
 Forum/Chat Info
 Enter Forum
 Lost Password

More Features
 Meet The Staff
 Contact Us/
 Change of Address
 Write For BHM
 Privacy Policy

Retired Features
 Country Moments
 Feedback
 Links
 Radio Show





  
 

BHM's Homesteading & Self-Reliance Forum
Posting requires Registration and the use of Cookies-enabled browser.

   

Go Back   BHM Forum > Homesteading > Food > Canning/Preserving

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-28-2010, 02:49 PM
Laura's Avatar
Laura Laura is offline
Grand Master Pontificator
 
Join Date: Jul 2009
Location: Zone 5
Posts: 2,300
Default Food Saver Malfunction?

I have a food saver mini.
It was working like a champ.......then it quit sealing.

When it was working, the light would come on.....then go off when it was sealed.
Now the light flashes, and the unit will not shut off and it gets HOT. I have to manually shut it down

What's up?
Reply With Quote

  #2  
Old 08-28-2010, 02:57 PM
nhlivefreeordie Male nhlivefreeordie is offline
Grand Master Pontificator
 
Join Date: Aug 2009
Location: Yeagertown PA
Posts: 3,319
Default

The flashing light indicates a problem of some sort. Vacuum pump clogged? Too much liquid in the heating element reservoir? Might just need a good cleaning.
Reply With Quote
  #3  
Old 08-28-2010, 04:25 PM
NCLee NCLee is offline
Grand Master Pontificator
 
Join Date: Jun 2009
Location: North Carolina
Posts: 5,174
Default

If you've been going fast and furious, it may be too hot. Some units require a short waiting period between each sealing. Don't know the specs on yours, so this may not apply. Check the manual to see if your unit requires a pause.

This thought is in addition to Wayne's. Juices or powder (if you sealing dry stuff) may have something clogged.

Just 2-cents. Hope you get it working soon.

Lee
__________________
We the People of the United States, in Order to form a more perfect Union, establish Justice, insure domestic Tranquility, provide for the common defence, promote the general Welfare, and secure the Blessings of Liberty to ourselves and our Posterity, do ordain and establish this Constitution for the United States of America.
Reply With Quote
Reply

Bookmarks


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -2. The time now is 12:24 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 1996 to Present. Backwoods Home Magazine, Inc.